[Logo] Codebox Software Forum
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Members]  Member Listing   [Groups] Back to home page 
[Register] Register / 
[Login] Login 
BitMeter OS web interface not working on OX 10.9
Forum Index » BitMeterOS
Author Message
Anonymous User



Hi

Running v0.7.5 on OS 10.9 but I'm getting an error saying "could not connect to localhost:2605"

I've tried Safari, Firefox and Chrome to open the web interface at:

http://localhost:2605/
http://localhost:2605/index.html

If I run bmclient -m monitor, I get:
BitMeter OS v0.7.5 Copyright © 2011 Rob Dawson
Licenced under the GNU General Public License

Unable to prepare SQL 'SELECT value FROM config WHERE key=?' rc=11 error=database disk image is malformed


I tried reinstalling BitMeter OS but that didn'r work.

Any idea what might be happening?
rob


Joined: 19/03/2008 18:27:35
Messages: 519
Offline

It looks like your database file has become corrupt - this is quite rare, but nasty when it happens. You can fix it by uninstalling BitMeter and ensuring that the bitmeter.db file has been completely removed from your system before reinstalling. A fresh install should fix things. If you have a lot of old data in your database that you want to keep then send me the file via email, and I'll see if I can recover anything from it for you
Rob
 
Forum Index » BitMeterOS
Go to:   
Powered by JForum 2.1.9 © JForum Team