[Logo] Codebox Software Forum
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Members]  Member Listing   [Groups] Back to home page 
[Register] Register / 
[Login] Login 
BitMeterOS unable to open database file when moved out of C:\ProgramData\BitMeterOS\
Forum Index » BitMeterOS
Author Message
Anonymous User

If I move the database anywhere else (changing the database system variable and rebooting) from the default location I cannot get the app to work.

When I run bmclient -ms I get an error "Unable to open database {path/to/database} rc=14 error=unable to open database file

Any ideas why please?

I've even tried reinstalling the app from scratch and then copying the clean bitmeter.db file to the destination folder and it still will not connect.

Looking at file permissions in the security tab tells me that my new db file has the same permissions as the original so I cannot see what that would be a problem.

I'm running Windows 8.1 64-bit.

The app works no problem if I install it clean, however I simply do not want the database file installing on my root partition.


Joined: 19/03/2008 18:27:35
Messages: 519

Are you sure that the update of the environment variable worked correctly, and that the update was for 'all users' and not just 'current user'? You should be able to check this from the Control Panel. It is also possible that there is a problem with this feature on Windows 8.1 - I don't have a system with this OS on, so can't check for myself.
Forum Index » BitMeterOS
Go to:   
Powered by JForum 2.1.9 © JForum Team